Функция Индекс в Excel

В этой статье мы будем рассматривать функцию ИНДЕКС(). Функция ИНДЕКС возвращает значение или ссылку на значение из таблицы или поименованного диапазона,  заданного номером строки и номером столбца.

Синтаксис функции ИНДЕКС довольно прост:
ИНДЕКС(массив, номер_строки, [номер_столбца])

Массив — обязательный аргумент, диапазон ячеек или константа массива.

Если массив содержит только одну строку или один столбец, аргумент «номер_строки» или «номер_столбца» соответственно не является обязательным. Если массив занимает больше одной строки и одного столбца, а из аргументов «номер_строки» и «номер_столбца» задан только один, то функция ИНДЕКС возвращает массив, состоящий из целой строки или целого столбца аргумента «массив».

Номер_строки — обязательный аргумент, номер строки в таблице, из которой требуется возвратить значение. Если аргумент «номер_строки» опущен, аргумент «номер_столбца» является обязательным.
Номер_столбца — необязательный аргумент, номер столбца в таблице, из которого требуется возвратить значение. Если аргумент «номер_столбца» опущен, аргумент «номер_строки» является обязательным.

Смотрите так же нашу статью о том, как использовать функцию ИНДЕКС и ПОИСКПОЗ в Excel с примером.

Напомним, что формулы массива заключаются в фигурные скобки { } и вводятся нажатием клавиш CTRL+SHIFT+ВВОД.) в горизонтальный диапазон ячеек для строки и вертикальный для столбца. Чтобы ввести формулу массива, нажмите клавиши CTRL + SHIFT + ВВОД.

Аргументы «номер_строки» и «номер_столбца» должны указывать на ячейку внутри заданного массива или тблицы, в противном случае функция ИНДЕКС возвратит значение ошибки #ССЫЛ!.

Рассмотрим пример использования функции Индекс, допустим у нас есть какая-либо таблица данных:

Данные

 Данные

 

Мы хотим при помощи функции Индекс вытащить значение «u» из таблицы. Значение «u» находится на пересечении Строки 2 и Столбца 3 (т.к. нумерация начинается с 0), т.о. формула имеет вид =ИНДЕКС(B2:E5;2;3):

Использование функции Индекс

Использование функции Индекс

 

Поделиться:
Нет комментариев

Добавить комментарий

Ваш e-mail не будет опубликован. Все поля обязательны для заполнения.