Функция ВПР в Excel (пример 2)

В статье «Функция ВПР в Excel с примером» мы рассмотрели основные понятия свзаные с функцией ВПР, синтаксис и пример использования функции. Сегодня мы рассмотрим пример использования функции ВПР, когда есть необходимость прописать быстро и много типовых функций ВПР.  Допустим, у нас есть таблица данных с информацией о товаре по артикулу, нам требуется по определенным товарам подтянуть часть/всю таблицу.

Имеем две таблицы, первая с исходными данными а вторая таблица, которую нужно заполнить:

Таблица данных

Таблица данных

пропишем в первую ячейку заполняемой таблицы обычную функцию ВПР =ВПР($A22;$A$4:$G$16;2;0):

Функция ВПР

Функция ВПР

Поменяем в функции ВПР цифру 2 (номер выводимого столбца) на переменную, в качестве которой будет выступать адрес ячейки и пропишем номера столбцов первой таблицы в строке 2 (т.е. мы не в самой формуле прописываем константу, а прописываем ее в ячейках, в формулах же будем ссылаться на эти ячейки). Таким образом, функция будет иметь вид:

=ВПР($A22;$A$4:$G$16;B$2;0)                :

Измененная Функция ВПР

Измененная Функция ВПР

Теперь протаскиваем функцию ВПР вниз и вправо:

Протаскиваем функцию ВПР

Протаскиваем функцию ВПР

Получили быстро заполненную таблицу (подтянули ВПРом данные по артикулу с динамическим номером солбца вывода):

Заполнение таблицы функцией ВПР

Заполнение таблицы функцией ВПР

Очень надеемся, что наша статья помогла Вам в решении Вашей проблемы. Будем благодарны, если Вы нажмете +1 и/или Мне нравится внизу данной статьи или поделитесь с друзьями с помощью кнопок расположенных ниже.

 

Поделиться:
3 Комментария
  • Александра:

    Огромное спасибо! Сначала не получалось из-за того, что неверно прописала формулу. На будущее всем: внимательно сморите, где стоят значки $ для формулы (до, между буквой и числом, или и до и между). И не забудьте пронумеровать столбцы.

  • апрпр:

    почему не получается подобное?

    • excel:

      Вы забыли пронумеровать столбцы. Смотрите вложение. Формулу я не менял

Добавить комментарий

Ваш e-mail не будет опубликован. Все поля обязательны для заполнения.