Функция ВПР в Excel (вложенные функции: ГПР в ВПР)

В статье Функция ВПР в Excel с примером мы рассмотрели основные понятия связанные с функцией ВПР, в статье Функция ВПР в Excel (пример 2) мы рассмотрели ввод переменной в функцию. В этой статье мы рассмотрим вложенные функции ГПР в ВПР.

Продолжим рассмотрение таблицы данных  статьи Функция ВПР в Excel (пример 2):

Данные для Примера

Итак, поставим задачу. Мы хотим, чтобы в отдельной таблице по заранее подготовленным артикулам подтягивались в соседний столбик нужные нам данные (либо стоимость, либо склад, либо др. значения).

Сначала организуем выпадающий список этих значений в ячейке B22 (Как это сделать описано в статье Как создать список в Excel) :

Список выбора значений

Список выбора значений

Теперь Номер выводимого столбца для функции ВПР мы найдем через функцию ГПР:

=ВПР(A23;$A$5:$G$17;ГПР($B$22;$B$3:$G$4;2;0);0)

Вложенные функции ГПР и ВПР

Вложенные функции ГПР и ВПР

Вот что у нас с вами получилось:

ВПР и ГПР(xlsx)

Очень надеемся, что наша статья помогла Вам в решении Вашей проблемы. Будем благодарны, если Вы нажмете +1 и/или Мне нравится внизу данной статьи или поделитесь с друзьями с помощью кнопок расположенных ниже. Спасибо.


Поделиться:
2 Комментария
  • Дарья:

    Здравствуйте!

    Вы бы не могли обновить ссылку Вот что у нас с вами получилось:

    ВПР и ГПР (xlsx)?

    Очень хотелось бы посмотреть на результат, но ссылка выдает ошибку

    • excel:

      Добрый день! Обновили ссылку на файл

Добавить комментарий

Ваш e-mail не будет опубликован. Все поля обязательны для заполнения.