Сумма в Excel

Давайте рассмотрим возможности суммирования в MS Excel.

Вычислять сумму в Excel можно двумя способами: через прямое суммирование ячеек и через функцию =СУММ(). 

Сегодня мы рассмотрим оба варианта суммирования, а также вывод суммы прописью.

Итак, первый вариант суммирования.

Этот вариант суммирования достаточно прост, в ячейку, в которой нам необходимо вывести сумму, нужно просто прописать через «+» необходимые ячейки для суммирования =A1+B1 :

сумма ячеек

сумма ячеек

Теперь рассмотрим вариант суммирования через функцию =СУММ(). В этом случае в функцию мы должны прописать диапазон значений для суммирования =СУММ(A1:B1) :

функция СУММ

функция СУММ

Изменив формат ячеек можно выводить функцию суммы не только прописью, но и добавлять необходимый текст до и после результата суммирования:

формат ячеек

формат ячеек

Рассмотрение функций суммирования мы на сегодня закончили, как видите суммировать в Excel достаточно просто.

В следующих статьях мы рассмотрим как использовать функцию суммы вместе с другими функциями.

Спасибо за внимание.

 

SirExcel.ru – Безграничные возможности Excel

 

Поделиться:
10 Комментариев
  • Богдан:

    Здравствуйте. Как совместить функции «сумм» и «левсимв»?

    Нужно просуммировать только левые символы, например ячейки [5;хв] [6;пп] [4;нп]и нужно просуммировать 5+6+4.

    Если бы были только числа было бы так:

    =СУММ(RC[-16]:RC[-1])

    Пытаюсь всунуть в формулу функцию «левсимв», а не получается...

    =СУММ(ЛЕВСИМВ(RC[-16]; 1):ЛЕВСИМВ(RC[-1];1)) что здесь не так?

    • excel:

      Добрый день! Квадратные скобки есть в тексте или вы так обозначили ячейку? если нет, то вам нужно в соседних трех столбцах с помощью ЛЕВСИМВ выделить эти цифры, а так же обернуть в функцию ЗНАЧЕН, чтобы превратить текст в числа и потом уже суммировать числа из этих столбцов. Ну либо сделать то же самое в одно столбце при просуммировать каждый столбец по отдельности, а не через сумм()

      • Богдан:

        Спасибо за ответ.

        Квадратные скобки — это обозначение ячейки.

        Про ЗНАЧЕН, нашел в ваших других ответах, не дождался немного)))

        Собственно так и сам сделал, думал может можно обойтись без дополнительных столбцов. Просто столбцов не 3, это массив 30×20.

        Мне еще надо было суммировать в зависимости от букв справа, и все вместе.

        Пришлось делать 3 вспомогательных массива.

        Например ячейки [5/хв] [6/пп] [4/нп]... и так несколько столбцов и строк.

        Первый массив выписывал «хв»

        =ЗНАЧЕН(ЕСЛИ(ПРАВСИМВ(R[-32]C;2)="хв";ЛЕВСИМВ(R[-32]C;1);0))

        потом суммировал в отдельный столбец, далее тоже самое с «пп» и «нп»

        ну и в конце суммировал все то есть «хв+пп+нп»

        Еще раз спасибо Вам за ответ.

  • Александр:

    Ситуация такая.

    Составлена таблица из допустим 10 столбцов с числами.

    В одних просто цифры или числа без формул.

    в других формулы типа сумма, разность и тд

    а в третьих применена функция «ЕСЛИ». И вот их по какой-то причине функция СУММ, когда выделяешь диапазон, не суммирует...

    если и так нет возможности понять проблему, может тогда связаться по эл. почте и я перешлю Книгу?

    • excel:

      Так понятнее, скорее всего итоговый результат, который выводится в ячейке с ЕСЛИ — текстовый, даже не смотря на то, что он выглядит у вас как цифры. Попробуйте формулу ЕСЛИ поместить в функцию ЗНАЧ()

      • Александр:

        Спасибо огромное за оперативные ответы! Проблема решена, избавили от механического суммирования отдельно каждых «битых» ячеек.

        Думаю, что буду чаще обращаться к вашему сервису.

  • Александр:

    Отказывается суммировать ячейки, где задана функция «если». Подскажите как выйти из этой ситуации?

    Спасибо.

    • excel:

      По вашем сообщению не понять в чем заключается проблема.

  • Алексей:

    Спасибо, а если необходимо суммировать ячейки, из диапазона, которые не пустые? поможет эта функция?

    • excel:

      Да, конечно. Если вы выделите диапазон, то функция просуммирует все числа, которые входят в этот диапозон

Добавить комментарий

Ваш e-mail не будет опубликован. Все поля обязательны для заполнения.