Как по дате найти первое число данного месяца в Excel

В этой статье мы посмотрим как по дате можно вернуть первое число данного месяца в Excel.

В комментариях к данной статье дали 2 более удобных способа:
=ДАТА(ГОД(E7);МЕСЯЦ(E7);1)
=КОНМЕСЯЦА(E7;-1)+1

То есть, например у нас есть ячейка с произвольной датой — например 30.08.2016. Нам необходимо по данной дате с помощью формул найти 01.08.2016 года. Стандартными способами я не нашел как это можно сделать. Можно по дате найти месяц, а вот первое число данного месяца нет.

В комментария задали вопрос, который и сподвиг написать данную статью о том как найти первое число месяца по дате.

Добрый день. Как написать формулу, где в двух ячейках нужно указать начало месяца и конец этого месяца, конец месяца он берет автоматически из другой ячейки (то есть она уже задаётся). Написал формулу ячейки дата -30, но когда в месяце 30 дней это формула не годиться (получается конец предыдущего месяца).

Решение задачи будет выглядеть следующим образом.

=ЗНАЧЕН("01."&ТЕКСТ(A1;"ММ")&"."&ТЕКСТ(A1;"ГГГГ"))

Где в A1 — дата, по которой нам необходимо определить 1 число этого месяца.

Суть решения задачи следующая:

1. Находим месяц указанной даты. Указав «ММ» — мы найдем месяц в формате двух чисел. Так, например август месяц будет 08, а не просто 8

ТЕКСТ(A1;"ММ")

2. Находим год указанной даты в формате 4-х чисел. В нашем случае это 2016

ТЕКСТ(A1;"ГГГГ")

3. С помощью знака & склеиваем первое число месяца 01 с полученными данными

01.+08+"."+2016

В итоге мы получаем 01.08.2016 — но это еще только текст. Чтобы он преобразовался в дату. Выражение нужно вставить в функцию ЗНАЧЕН()

Поделиться:
6 Комментариев
  • ExcelSkype says:

    По моему, лучше использовать для решения задачи нахождения первого дня месяца по произвольной дате месяца более простые формулы:

    =ДАТА(ГОД(E7);МЕСЯЦ(E7);1)

    =КОНМЕСЯЦА(E7;-1)+1

    Эти формулы, в отличие от формулы, которая приведена в статье будут корректно работать в любом экселе начиная с версии 2007 (я имею ввиду, что не важно на каком языке эксель — какая локализация у эксель)

    • excel says:

      Супер! Спасибо, добавил в статью

      • VUGGI says:

        =ТЕКСТ(A1;"ММММ"&"ГГГГ")+0

        можно еще и так

        • excel says:

          Спасибо, это очень интересно. Как это работает? На что влияет тут ноль?

          • Алекс says:

            Можно еще умножить на 1 (=ТЕКСТ(A1; «ММММ»& «ГГГГ»)*1), это нужно чтобы система поняла что необходима дата не в текстовом, а в числовом формате.

          • excel says:

            Отлично. Спасибо за отличное дополнение.

Добавить комментарий

Ваш e-mail не будет опубликован. Все поля обязательны для заполнения.