Функция ЕСЛИ в Excel с примерами

Одна звездаДве звездыТри звездыЧетыре звездыПять звёзд (3 оценок, в среднем: 3,67 из 5)
Loading...Loading...

Сегодня мы рассмотрим функцию ЕСЛИ.

Функция ЕСЛИ часто используется в Excel для решения многих задач. Знать ее очень полезно. В данной статье мы попробуем рассказать про ее работу на простых примерах, достаточно один раз разобраться с конструкцией функцией ЕСЛИ и вы сможете применять ее и в самых сложных вариантах.

Функция ЕСЛИ проверяет, выполняется ли условие, и возвращает одно значение, если оно выполняется, и другое значение, если нет.

Синтаксис функции ЕСЛИ очень простой:

ЕСЛИ(лог_выражение; [значение_если_истина]; [значение_если_ложь])

лог_выражение – это любое значение или выражение, которое при вычислении дает значение ИСТИНА или ЛОЖЬ.

Что это значит?  Выражение при вычислении дает значение ИСТИНА если это выражение верно.

В этой части необходимо проверить на соответствие выражения.

Например:

=ЕСЛИ(А1=10; [значение_если_истина]; [значение_если_ложь])  - если А1 равно 10, то выражение  А1=10 даст значение ИСТИНА, а если не равно 10, то ЛОЖЬ

Другой пример

=ЕСЛИ(А1>30; [значение_если_истина]; [значение_если_ложь])  - если в ячейки А1 число больше 30, то А1>30 вернет ИСТИНА, а если меньше, то ЛОЖЬ

Еще пример

=ЕСЛИ(С1=”Да”; [значение_если_истина]; [значение_если_ложь])  - если в ячейки C1 содержится слово “Да” то выражение вернет значение ИСТИНА, а если нет, то С1=”Да” вернет ЛОЖЬ

Надеюсь с этим понятно, поехали дальше. Рассмотрим следующие компоненты функции ЕСЛИ

=ЕСЛИ(лог_выражение; [значение_если_истина]; [значение_если_ложь])

значение_если_истина, значение_если_ложь – как видно из их названия, это то что необходимо сделать в зависимости от того, что вернул лог выражения: ИСТИНА и ЛОЖЬ

Пример использования функции ЕСЛИ в Excel

Рассмотрим использование функции ЕСЛИ на практическом примере. У нас есть таблица заказов, которую мы использовали при рассмотрении работы функции ВПР. Нам необходимо заполнить столбец «Заказы столов», то есть необходимо выбрать только заказы столов. Это можно сделать различными способами,  но мы с вами будет использовать функцию ЕСЛИ, чтобы показать ее работу на примере. (см.рисунок)

Функция ЕСЛИ в Excel с примерами

Для решения поставленной задачи напишем формулу с использованием функции ЕСЛИ

=ЕСЛИ(A3="Ведро";D3;"-") и нажмем Enter

Функция ЕСЛИ в Excel с примерами

Как вы смогли заметить аргументы функции ЕСЛИ разделены точкой с запятой.

Итак, первый аргумент (лог выражения) A3="Ведро" проверяет содержится ли в ячейке А3 слово «Ведро», если содержится, то выполняется второй аргумент функции ЕСЛИ (значение_если_истина), в нашем случае это D3 (т.е стоимость заказа),  если в ячейка А3 не равна слову «Ведро», то выполняется третий аргумент функции ЕСЛИ (значение_если_ложь), в нашем случае это «-» ( т.е будет написано тире).

Таким образом, в ячейки E3 появится значение D3, т.е число 240.

Далее необходимо протянуть формулу вниз для остальных значений. Для этого необходимо выделить ячейку  Е3 и потянуть вниз за нижний правый угол (смотрите рисунок 3)

Функция ЕСЛИ в Excel с примерами

Итоговый результат работы функции ЕСЛИ вы можете посмотреть на рисунке 4.  Функцию ЕСЛИ можно использовать в очень многих ситуациях. Находить ошибки, находить уникальные значения в списке, использовать многократные проверки на выполнение условий. Разбор всех этих приемов Excel ждет вас впереди.

Если статья была Вам полезна, то будем благодарны, если Вы поделитесь ей со своими друзьями с помощью кнопок расположенных ниже.

Спасибо за внимание.


 

Поделиться:

83 Комментария

  • Алексей:

    Что делать если при вводе формулы с использованием «ЕСЛИ» число уровней вложенности превышает 64?!

  • Оксана:

    Помогите пожалуйста с формулой, третий день бьюсь, все никак.

    Лист1-таблица в которой необходимо чтобы автоматически вносились данные о сотрудниках(их всего 103 чел., но в таблице будет только 5 чел.)

    Хотелось бы, чтобы при ручном вводе только таб.№(А) — ФИО(D) и №страховки(E)автоматически подтягивались из Листа 2.

    Лист2-Список таб.№ (С3:С105), ФИО сотрудников(Д3:Д105), №страховки (Е3:Е105).

  • Алёна:

    Подскажите пожалуйста как найти надбавку за стаж- Если стаж работы не превышает 5 лет, то надбавка за стаж равна (10+n)% от оклада, от 5 до 10 лет (15+n)% от оклада и свыше 10 лет – (20+n)% от оклада. При вычислениях используется функция ЕСЛИ()

    • excel:

      =ЕСЛИ(A1<5;(10+n)%;ЕСЛИ(A1>5;(20+n)%;(15+n)%))

      Как-то так, вместо (10+n)% — указать расчет оклада, A1 — это стаж

  • юлия:

    Здравствуйте, такая задача, есть формула ЕСЛИ(СУММ(А1:А2)=0; «ИДИТЕ»; А1/А2) при значении А2=0, выдается ошибка «Деление на ноль». Как переписать эту формулу, чтобы избежать ошибки.

    • excel:

      Добрый день! Ошибка никуда не пропадет, ее можно только скрыть.

      =ЕСЛИОШИБКА(ЕСЛИ(СУММ(A1:A2)=0; «ИДИТЕ»; А1/А2); "")

      если будет ошибка, то будет пусто

  • Ольга:

    Да конечно скачала.Но у меня не получается. Нажимаю «вставить функцию ЕСЛИ». Выходит табличка, где нужно расписаться лог. Выражение, истину и ложь. Спасибо за помощь-не буду Вас больше беспокоить

    • excel:

      Вот решение. Отличие только в том, что в первом случае «вид занятий» и ставка вынесены для удобства в отдельную табличку, а тут все в формуле написал. Насколько я понял, что вам именно так надо без лишних табличек

      yadi.sk/i/tm0JJ8DZexPtq

    • excel:

      Если не разберетесь, то пришлите сам файл на info@sirexcel.ru

      Если там нужно только формулу прописать, я вам сделаю

    • excel:

      В вашем случае, проверка будет на то, что в ячейке «Вид занятий» равно «Индивидуальные занятия», если равно, то это истина и будет перемножение коэ-та, если не равно, то снова проверка на если, проверяется если ячейка в «Вид занятий» равно «Групповые занятия», если равно, то идет перемножение кол-ва часов на соответствующий коэ-т, если нет, то снова проверка.

  • Ольга:

    Файл с заготовкой

  • Ольга:

    Доброе утро! Вот заготовка к и условия задачи. Никак не пойму в данной задаче что является истиной, что ложью. Подскажите пожалуйста.Задача: Поле "Оплата инструктору " вычислить по формуле (используйте функцию ЕСЛИ) исходя из тарифа- дежурство в зале-120 руб. за час, инд. занятия- 200 руб. за час, гр. занятия- 180 руб. за час.

    Дата Инструктор Вид занятия Название тренировки Длительность тренировки Оплата инструктору

    01.02.2015 Иванов. А.А. Индивидуальные занятия Йога 2

    02.02.2015 Петров С.С. Групповые занятия Аэробика 1,5

    03.02.2015 Сидоров М.М. Групповые занятия Фитнес 1,5

    04.02.2015 Семенов П.П. Дежурство в зале Плавание 1

    05.02.2015 Котов К.К. Индивидуальные занятия Аквааэробика 1

    06.02.2015 Иванов. А.А. Индивидуальные занятия Йога 2

    07.02.2015 Петров С.С. Дежурство в зале Аэробика 1,5

    08.02.2015 Сидоров М.М. Групповые занятия Фитнес 1,5

    09.02.2015 Семенов П.П. Групповые занятия Плавание 1

    10.02.2015 Котов К.К. Индивидуальные занятия Аквааэробика 1

    11.02.2015 Иванов. А.А. Индивидуальные занятия Йога 2

    12.02.2015 Петров С.С. Групповые занятия Аэробика 1,5

    13.02.2015 Сидоров М.М. Дежурство в зале Фитнес 1,5

    14.02.2015 Семенов П.П. Групповые занятия Плавание 1

    15.02.2015 Котов К.К. Индивидуальные занятия Аквааэробика 1

    16.02.2015 Иванов. А.А. Индивидуальные занятия Йога 2

    17.02.2015 Петров С.С. Групповые занятия Аэробика 1,5

    18.02.2015 Сидоров М.М. Групповые занятия Фитнес 1,5

    19.02.2015 Семенов П.П. Групповые занятия Плавание 1

    20.02.2015 Котов К.К. Индивидуальные занятия Аквааэробика 1

    21.02.2015 Иванов. А.А. Дежурство в зале Йога 2

    22.02.2015 Петров С.С. Групповые занятия Аэробика 1,5

    23.02.2015 Сидоров М.М. Групповые занятия Фитнес 1,5

    24.02.2015 Семенов П.П. Групповые занятия Плавание 1

    25.02.2015 Котов К.К. Индивидуальные занятия Аквааэробика 1

    26.02.2015 Сидоров М.М. Групповые занятия Фитнес 1,5

    27.02.2015 Семенов П.П. Групповые занятия Плавание 1

    28.02.2015 Котов К.К. Дежурство в зале Аквааэробика 1

  • Ольга:

    Добрый день! Помогите пожалуйста решить задачу: рассчитать оплату инструктора по фитнесу используя функцию ЕСЛИ, если известны тарифы оплаты за 1 час: дежурство-120 руб, групповые занятия-180 руб, индивидуальные занятия-200 руб. Спасибо заранее

    • excel:

      Лучше использовать ВПР в данном случае

      yadi.sk/i/jFcg6BRHewhqo

      • Ольга:

        Напишите пожалуйста еще формулу с функцией ЕСЛИ

        • excel:

          Ольга, а я что написал? Если не то, что надо, тогда задавайте вопрос более полно, плюс приложите файл с заготовкой.

      • Ольга:

        Спасибо большое за вариант, но задача состоит именно в использовании функции ЕСЛИ

  • Станислав:

    Доброго времени суток!

    Помогите, пожалуйста, написать формулу, которая бы помогла выбрать минимальное значение из трёх при различных курсах и заполняемости таблицы.

    Имеется:

    D2 — Доллар

    E2 — Евро

    F2 — Фунт

    D6 =450

    E6 =350

    F6 =250

    Курсы (доллар, евро, фунт к рублю):

    L15 =60

    L16 =70

    L17 =90

    В ячейке G6 необходимо рассчитать МИНИМАЛЬНУЮ сумму в рублях (без использования доп. ячеек), при условии, что значение «0», либо пустая ячейка с ценой не будет приниматься во внимание (в противном случае минимальное значение будет «0»).

    Формула ниже работает, но если значениях всех ячеек указаны и больше «0»:

    МИН(ЕСЛИ(D6=0;МИН(E6*L16;F6*L17);МИН(D6*L15;E6*L16;F6*L17));ЕСЛИ(E6=0;МИН(D6*L15;F6*L17);МИН(D6*L15;E6*L16;F6*L17));ЕСЛИ(F6=0;МИН(D6*L15;E6*L16);МИН(D6*L15;E6*L16;F6*L17)))

    ЛИБО:

    =ЕСЛИ(ИЛИ(D6=0;E6=0;F6=0); «ПРОБЛЕМА»;МИН(D6*L15;E6*L16;F6*L17))

    Стоит указать в одной из ячеек значение «0» или вовсе ничего не указывать, то выражение обнуляется.

    • excel:

      Как вариант так

      =МИН(ЕСЛИ(D6=0;100000;D6)*L15;ЕСЛИ(E6=0;100000;E6)*L16;ЕСЛИ(F6=0;100000;F6)*L17)

      где 100000 это максимальное число, которое не может быть ценой в реальном примере

      • Станислав:

        Спасибо!!! На это фантазии не хватило)))

  • Дима:

    Помогите сделать в Excal

    • excel:

      Добрый день! Такие задачи я не решаю, хоть она и простенькая. Подготовьте полностью таблицу, внесите данные, и если потребуется составить формулу, я помогу. А так у меня времени нет это делать за вас)

  • Дима:

    Автогонщик участвовал в пяти этапах соревнований. Известны средняя скорость движения автомобиля на каждом из этапов (в км/час) и время, затраченное на прохождение дистанции этапа (в час). Подготовить лист для определения общей длины тех этапов, на которых средняя скорость движения автомобиля была больше 200 км/час.

  • VICK:

    Здравствуйте, помогите, пожалуйста. Я не большой специалист в использовании формул, но вот методом тыка дошла до следующей формулы, дающей мне желаемый результат: =IF (F4=Lists!B3;Expenses!E4;0)+IF (Expenses!F5=Lists!B3;Expenses!E5;0)+ и т.д.

    Смысл в том, что значение столбца F всегда должно быть равно значению ячейки B3 вкладки Lists. Если условие выполняется, следует выбирать значение столбца E, того же ряда. Все выбранные значения затем суммируются. Формула в таком виде работает, но забивать вручную все ячейки столбца F для сравнения просто не реально!

    Модет есть какой-то другой способ?

    • excel:

      Без файла не очень понятно, но как я понял, вы можете сделать следующим способом

      =IF (F4=Lists!$B$3;Expenses!E4;0)

      закрепите B3 и тогда можно протянуть формулу на все строки, а потом все просуммировать.

      2-й способ, это просто в одной ячейке с помощью функции СУММЕСЛИ

  • Андрей:

    Здравствуйте всем. Очень ценная информация!!! А кто-нибудь занимался составлением графика учета рабочего времени с дневными и ночными сменами? Мне нужно сделать так, чтоб отдельно считались дневные и ночные часы. То есть, если в графике стоит 12, значит 12 считаются как дневные, а вот с ночными сложности..Человек заступает на смену в 20:00, и до 22:00 идут 2 часа дневных, и так же утром с 6:00 до 8:00 тоже 2 часа дневных.. в графике ставят 4 и 8 часов в разные дни, но из них по 2 часа получаются дневные.. вот как бы задать такое условие, чтобы дневные часы считались в одной ячейке, а ночные в другой.. Заранее благодарен, если кто-нибудь поможет!!!

  • Алена:

    Спасибо все получилось, формула следующая =ИНДЕКС(Лист1!B:B;ПОИСКПОЗ(B8;Лист1!A:A;0);1)

    • excel:

      Ну я вам так и написал

      «Ой, сорри. Номер столбца нужно указать как 1, CTRL + SHIFT + ВВОД нажимать не надо

      =ИНДЕКС(Лист1!B:B;ПОИСКПОЗ(B8;Лист1!A:A;0);1)»

  • Алена:

    0 потому что точное сопоставление. написала 1 все равно пишет ссылка

  • Алена:

    я скопировала данные на новый лист, получилась такая формула =ИНДЕКС(Лист1!B:B;ПОИСКПОЗ(B8;Лист1!A:A;0);Лист1!B:B)

    но при нажатии кновки ввод или комбинации CTRL + SHIFT + ВВОД

    он мне пишет в ячейке «ссылка»

    Что не так сделала?

    • excel:

      И Алена, вы написали формулу с Лист1, Лист1 это лист с ссылками на другую книгу? и при этом вы находитесь и прописываете саму формулу на другом листе? так?

      • Алена:

        Нет,. на Лист1 располагаются данные без ссылок на другую книгу, формулу создаю на Лист2 в этой же книге

    • excel:

      Почему пишите 0? CTRL + SHIFT + ВВОД нажимать не надо

      =ИНДЕКС(Лист1!B:B;ПОИСКПОЗ(B8;Лист1!A:A;1);Лист1!B:B)

      • excel:

        Ой, сорри. Номер столбца нужно указать как 1, CTRL + SHIFT + ВВОД нажимать не надо

        =ИНДЕКС(Лист1!B:B;ПОИСКПОЗ(B8;Лист1!A:A;0);1)

  • Алена:

    У меня другой вопрос, можно ли эту функцию {=ИНДЕКС(K:K;ПОИСКПОЗ(B8;J:J;0);K:K)} переделать так чтобы диапозоны были из другой книги

    • excel:

      Чтобы не использовать CTRL + SHIFT + ВВОД, вместо K:K необходимо указать 1 — это номер столбца, он у вас один. Вот такую формулу и попробуйте на с другой книгой, я не помню будет она работать или нет.

      Если не будет, то делаете новый лист, там в ячейке A1 прописываете формулу Ваша_другая_книга_A1 и протягиваете вниз и влево, то есть делаете копию данных, простой ссылкой. При открытии данные будут обновляться, Индекс используете ссылкой на эту страницу. Потом можете скрыть этот лист, чтобы не мешал.

  • Алена:

    Добрый вечер. У меня формула есть: =ЕСЛИ(B8=[Книга3]Лист1!$A$1;[Книга3]Лист1!$B$1;0)

    Но у меня проблема заключается в следующем: вместо $A$1 и $B$1 мне нужно вставить диапозон. В итоге должно получиться следующее: лог_выражение после знака = должно выбирать из диапозона нужное значение, а ИСТИНА должна выбираться также из диапозона

    • excel:

      Добрый день! Нужно либо делать много вложенных ЕСЛИ, либо использовать обычную ПОИСКПОЗ — смысл в том, что используя ПОИСКПОЗ функция будет пытаться найти искомое значение B8 в столбце диапазона (который вместо $A$1), если найдет, то выдаст номер строки (порядковый номер строки в указанном диапазоне), если не найдет, то будет ОШИБКА Н/Д. Далее используете один раз функцию ЕСЛИ. Если ошибка, например, пусто, если не ошибка, то используете функцию ИНДЕКС — =ИНДЕКС(диапазон_тот_что_вместо_$B$1;номер_найденной_строки_в_виде_формулы; столбец_1)

      • Алена:

        Не получается. Формула получилась следующая: =ИНДЕКС(J:K;ПОИСКПОЗ(B8;J:J;0);K:K)

        В8 — артикул

        Диапозон J:J — артикулы

        Диапозон K:K — Цена

        После написания формулы должна выходить цена, поиск по артикулу

        • Алена:

          Спасибо, забыла нажать сочетание клавиш CTRL + SHIFT + ВВОД, а в итоге формула получилась следующая {=ИНДЕКС(K:K;ПОИСКПОЗ(B8;J:J;0);K:K)}

  • Евгения:

    Добрый день, помогите пожалуйста не могу разобраться.

    Мне нужно

    Базовая ставка- 15 000,00

    от 1 года до 2 лет — 10%-0,10

    от 2 лет до 3 лет — 20%-0,20

    от 3 до 4 лет — 30%-0,30

    от 4 до 5 лет — 40%-0,40

    свыше 5 лет — 50%-0,50

    Т.е. Если стаж от 1 до 2 лет, то базовая ставка умножить на коэффициент 0,1 и так все годы. Прописать формулой помогите пожалуйста.

    • excel:

      Добрый день! Совсем недавно, как раз, рассматривали интересное решение к данной задаче. Если не решили вопрос, то пишите — поможем

      vk.com/topic-57633334_30146627?post=89

  • ирина:

    ООО, получилось, спасибо еще раз!!!

  • ирина:

    так вы имели ввиду ЕСЛИ(I3<=2400000);18%*I3;ЕСЛИ(I3<=580000);432000+23%*(I3-2400000);ЕСЛИ(I3<=9300000);1214+28%*(I3-5800000);ЕСЛИ(I3<=13000000);2194000+34%*(I3-9300000);3452000+40%*(I3-13000000)))))

    • excel:

      А зачем вы добавили лишние скобки во многие выражения ЕСЛИ(I3< =2400000);18%*I3

      Пишите одно, потом исправляете.

      =ЕСЛИ(I3< =2400000;18%*I3;ЕСЛИ(I3<=58000;432000+23%*(I3-2400000);ЕСЛИ(I3<=9300000;1214+28%*(I3-5800000);ЕСЛИ(I3<=13000000;2194000+34%*(I3-9300000);3452000+40%*(I3-13000000)))))

  • ирина:

    Так тоже не получается, выдает что неправильно введен знак равенства и минус

    • excel:

      Пришлите итоговую формул (исправленную), которая не прнимается

  • ирина:

    Что не так в этой функции? мне выдает что неправильно введен знак равенства и минус, подскажите пожалуйста) ЕСЛИ(I3<=2400000;18%*I3;ЕСЛИ(I3<=580000;432000+23%*(I3-2400000);ЕСЛИ(I3<=9300000;1214+28%(I3-5800000);ЕСЛИ(I3<=13000000;2194000+34%(I3-9300000);3452000+40%(I3-13000000)))))

    • excel:

      Добрый день! Во второй части формулы, начиная с 28%(I3-5800000) и до конца, у вас не стоит знак умножить после процентов.

      • ирина:

        Большое спасибо!

  • Наталья:

    Я ошиблась

    Как составить формулу: Если сумма заказа превышает Nсуммы, то НДС 35%, а если сумма меньше или равно Nсуммы, то 40%

    • Юлия:

      у меня было похожее условие если план выполнен меньше чем на 10%, то премии нет, если выполнен больше чем 10% но менее 20%, то премия 5% и, т. д. я записала следующее

      в ячейке С сумма 100% бонуса, в ячейке F — просчитывался процент выполнения, в ячейке G я прописала формулу, отвечающую этим условиям, вот она =ЕСЛИ(И(F3F3;F3>=10);C3*0,05;ЕСЛИ(И(30>F3;F3>=20);C3*0,1;ЕСЛИ(И(40>F3;F3>=30);

      C3*0,15;ЕСЛИ(И(50>F3;F3>=40);C3*0,2;ЕСЛИ(И(60>F3;F3>=50);C3*0,25;

      ЕСЛИ(И(70>F3;F3>=60);C3*0,3;ЕСЛИ(И(80>F3;F3>=70);C3*0,35;ЕСЛИ(И(85>F3;F3>=80);

      C3*0,4;ЕСЛИ(И(90>F3;F3>=85);C3*0,5;ЕСЛИ(И(95>F3;F3>=90);C3*0,65;

      ЕСЛИ(И(100>F3;F3>=95);C3*0,75;ЕСЛИ(И(105>F3;F3>=100);C3*1;

      ЕСЛИ(И(110>F3;F3>=105);C3*1,03;ЕСЛИ(И(F3>=110);C3*1,07)))))))))))))))

  • Наталья:

    Как составить формулу: Если сумма заказа превышает Nсуммы, то НДС 35%, а если сумма меньше или равно Nсуммы, то 35%

  • Григорий:

    мне нужна помощь

  • OLEG:

    спасибо за дельные советы...

  • Oleg:

    а вот полный вариант раз так.

  • Oleg:

    ЧМ — Занимаемое командой место определяется по следующим критериям:

    – наибольшее количество очков;

    – лучшая разница забитых и пропущенных мячей;

    – наибольшее количество забитых мячей.

    ЧЕ — место в группе определяется по следующим критериям:

    – большее количество турнирных очков, полученных командами во встречах друг с другом;

    – лучшая разница забитых и пропущенных голов во встречах друг с другом;

    – большее количество голов, забитых в матчах друг с другом;

    т.е если на пример Бразилия и Мексика набрали одинаковое кол-во очков и у Бразилии разница мячей 5-3=2, а у Мексики — 3-3=0 и между собой сыграли Бразилия-Мексика 0-1, то в ЧМ выше будет Бразилия, а в ЧЕ — Мексика (личная встреча). ЧЕ — При равенстве очков у трёх команд вообще нужна таблица отдельно для них, а потом вернуться в основную (наверное коряво закрутил...). Не могу никак это всё оформить.

    • Oleg:

      столбцы забыл скрытые с формулами открыть...

  • Oleg:

    вот...

    • excel:

      Напишите, подробно в чем состоит задача.

  • Oleg:

    есть электронная таблица ЧМ по футболу, нужна помощь для составления таблицы ЧЕ (другой регламент распределения мест в группе при равенстве очков у двух и более команд). ????

    • excel:

      Без примера ничего не понятно

      • Oleg:

        у меня файл 716КБ

        • excel:

          Поменял настройки на 2мб

          • Oleg:

            у меня был файл xls. и вставки изображения, всё исправил...

      • Oleg:

        а куда пример вставить ???

  • Oleg:

    вот пример:

    =ЕСЛИ(ИЛИ(A2="!!! «;В2=»!!!;С2="!!! «;D2=»!!! ";и т. д.); "!!! "; "") т.е. проверяю столбец на наличие хотя бы одного "!!! "

    это перечисление набираю вручную, а можно ли как то быстрее ??? или другим способом ???

    • excel:

      Олег, на первый взгляд только так, но все зависит от конкретной задачи.

      Свободны ли данные под A2, B2 и т.д. ? важно ли для вас знать в каком столбце будет находится значение !!! или просто нужно знать есть в каком либо столбце или нет

      • Oleg:

        я немного ошибся..

        вот как

        =ЕСЛИ(ИЛИ(A2="!!! «;А3=»!!! «;А4=»!!! «;А5=»!!! ";и т. д.); "!!! "; "") т.е. проверяю столбец на наличие хотя бы одного "!!! "

        в ячейке А1 должно быть "!!! " если хотя бы в одной из ячеек столбца после А2 есть "!!! ". в какой строке не важно.

        Спасибо..

        • excel:

          Так, нет. Эта функция не будет работать. Используйте просто ВПР

          =ВПР("!!! ";$A$2:$A$12;1;0)

          Если есть, то вернется это значение, если нету такой ячейки, то будет ошибка

        • excel:

          Тогда можете воспользоваться функцией ПРОСМОТР

          =ПРОСМОТР("!!! ";A2:A12)

          Если в массиве A2:А12 будет ячейка с !!!, то вернется !!!, если нет, то будет ошибка. Вот от этого и отталкивайтесь

          • Oleg:

            работает как я хотел, здорово...

          • excel:

            Тогда так: =ЕСЛИОШИБКА(ВПР("!!! ";$A$2:$A$12;1;0); "")

          • excel:

          • Oleg:

            только хотелось бы при отсутствии !!! не ошибку, а пустую ячейку.

          • Oleg:

            понял, спасибо...

Добавить комментарий

Ваш e-mail не будет опубликован. Все поля обязательны для заполнения.