Функция ЕСЛИ в Excel с примерами

Сегодня мы рассмотрим функцию ЕСЛИ.

Функция ЕСЛИ часто используется в Excel для решения многих задач. Знать ее очень полезно. В данной статье мы попробуем рассказать про ее работу на простых примерах, достаточно один раз разобраться с конструкцией функцией ЕСЛИ и вы сможете применять ее и в самых сложных вариантах.

Функция ЕСЛИ проверяет, выполняется ли условие, и возвращает одно значение, если оно выполняется, и другое значение, если нет.

Синтаксис функции ЕСЛИ очень простой:

ЕСЛИ(лог_выражение; [значение_если_истина]; [значение_если_ложь])

лог_выражение – это любое значение или выражение, которое при вычислении дает значение ИСТИНА или ЛОЖЬ.

Что это значит?   Выражение при вычислении дает значение ИСТИНА если это выражение верно.

В этой части необходимо проверить на соответствие выражения.

Например:

=ЕСЛИ(А1=10; [значение_если_истина]; [значение_если_ложь])  - если А1 равно 10, то выражение  А1=10 даст значение ИСТИНА, а если не равно 10, то ЛОЖЬ

Другой пример

=ЕСЛИ(А1>30; [значение_если_истина]; [значение_если_ложь])  - если в ячейки А1 число больше 30, то А1>30 вернет ИСТИНА, а если меньше, то ЛОЖЬ

Еще пример

=ЕСЛИ(С1=”Да”; [значение_если_истина]; [значение_если_ложь])  - если в ячейки C1 содержится слово “Да” то выражение вернет значение ИСТИНА, а если нет, то С1=”Да” вернет ЛОЖЬ

Надеюсь с этим понятно, поехали дальше. Рассмотрим следующие компоненты функции ЕСЛИ

=ЕСЛИ(лог_выражение; [значение_если_истина]; [значение_если_ложь])

значение_если_истина, значение_если_ложь – как видно из их названия, это то что необходимо сделать в зависимости от того, что вернул лог выражения: ИСТИНА и ЛОЖЬ

Пример использования функции ЕСЛИ в Excel

Рассмотрим использование функции ЕСЛИ на практическом примере. У нас есть таблица заказов, которую мы использовали при рассмотрении работы функции ВПР. Нам необходимо заполнить столбец по заказам Ведер (ошибочно на картинке указано «Заказы Cтолов»), то есть необходимо выбрать только заказы с Ведрами. Это можно сделать различными способами,   но мы с вами будет использовать функцию ЕСЛИ, чтобы показать ее работу на примере. (см.рисунок)

Функция ЕСЛИ в Excel с примерами

Для решения поставленной задачи напишем формулу с использованием функции ЕСЛИ

=ЕСЛИ(A3="Ведро";D3; «-») и нажмем Enter

Функция ЕСЛИ в Excel с примерами

Как вы смогли заметить аргументы функции ЕСЛИ разделены точкой с запятой.

Итак, первый аргумент (лог выражения) A3="Ведро" проверяет содержится ли в ячейке А3 слово «Ведро», если содержится, то выполняется второй аргумент функции ЕСЛИ (значение_если_истина), в нашем случае это D3 (т.е стоимость заказа),  если в ячейка А3 не равна слову «Ведро», то выполняется третий аргумент функции ЕСЛИ (значение_если_ложь), в нашем случае это «-» (т.е будет написано тире).

Таким образом, в ячейки E3 появится значение D3, т.е число 240.

Далее необходимо протянуть формулу вниз для остальных значений. Для этого необходимо выделить ячейку  Е3 и потянуть вниз за нижний правый угол (смотрите рисунок 3)

Функция ЕСЛИ в Excel с примерами

Итоговый результат работы функции ЕСЛИ вы можете посмотреть на рисунке 4.  Функцию ЕСЛИ можно использовать в очень многих ситуациях. Находить ошибки, находить уникальные значения в списке, использовать многократные проверки на выполнение условий. Разбор всех этих приемов Excel ждет вас впереди.

Если статья была Вам полезна, то будем благодарны, если Вы поделитесь ей со своими друзьями с помощью кнопок расположенных ниже.

Спасибо за внимание.


 

Поделиться:
188 Комментариев
  • Роман:

    вложение  1.xlsx

    Здравствуйте! Выручите чем сможете))

    • excel:

      Если вам необходимо, чтобы не проданные товары вообще не появлялись в отчете. То сначала вам нужно формулами сформировать список проданных товаров, потом по товару уже можно подтянуть нужные данные. Для формирования списка воспользуйтесь вот этой статьей

      sirexcel.ru/priemi-excel/...yu-formul-excel/

  • Lexx:

    Добрый день. Помогите составить формулу, вставляющую значение по 3-м условиям, но не суммирующую. «СУММЕСЛИМН» не подойдет.

  • Орманжи Виктор:

    вложение  .xlsx

    Здравствуйте помогите построить формулу. Я дал в каментарии файл по которому необходимо создать формула расчет необходимого количества товаров на основании продаж (колонка расход) на определенный период(в будущее) на оснавание потребности магазина учитывая его остатки, так же необходимо что бы учитывались остатки колонки СКЛАД, потребность должна учитывать наличие остатка на складе.

    • excel:

      А как должна считаться потребность? из чего складываться?

  • Татьяна:

    вложение  -тест.xlsx

    Помогите, пожалуйста, составить формулу в ячейке с результатом, с использованием функции ЕСЛИ

  • Сергей:

    Здравствуйте.

    Прошу прощения, если уже есть ответ на мой вопрос, но я почитал и не увидел.

    Хочу понять как подставлять «ая» или «ый» в зависимости от окончания слова. Зная, что многие женские имёна (распространённые), оканчиваются на «а» и «я».

    Можно ли написать "если слово оканчивается на «а», то значение такое, если нет то такое)

    • excel:

      Можно. Сначала с помощью функции ПРАВСИМВ — находите последний символ имени.

      После этого с помощью если проверяете.

  • Ольга:

    вложение Capture

    Добрый день. Помогите определить формулу по данному заданию. Спасибо!

    • excel:

      В первом случае будет

      ЕСЛИ(ИЛИ(1кв>1000;2кв>1000..);"Шанс есть";"Нет")

      Второе

      ЕСЛИ(И(1кв>1000;2кв>1000..);"Молодцы";"Нет")

      Вместо 1кв и так далее ссылки на ячейки

  • Алина:

    Подскажите как я могу использовать функцию ЕСЛИ или другой способ в Екселе?

    Сначала нужно сделать выбор из выпадающего списка значений (текстовых, например, шкаф, комод, тумбочка,) а затем с помощью функции Если определить правильный выбор для перехода по гиперсссылке по листам?

    • excel:

      Добрый день! Делаете выпадающий список, а потом используете sirexcel.ru/priemi-excel/...xcel_s_primerom/

      Хотя не совсем понимаю, как можно гиперссылку вернуть по впр.

      Думаю лучше макросами. Делаете выпадающий список или кнопки и по выбору ставите переключение листа

  • Дима:

    Будьте добры, подскажите пож-та, какую указать формулу, если необходимо задать

    такое условие: есть шесть цифр, и если каждая из них больше последующей (т.е видим рост), то ставится оценка «1», а если нет, до «2». Огромное спасибо!!

  • Ранис:

    Добрый день. Как написать формулу, где в двух ячейках нужно указать начало месяца и конец этого месяца, конец месяца он берет автоматически из другой ячейки(то есть она уже задаётся). Написал формулу ячейки дата-30, но когда в месяце 30 дней это формула не годиться (получается конец предыдущего месяца).

    • Юрий:

      Написал отдельную статью на ваш вопрос с объяснениями

      sirexcel.ru/priemi-excel/...mesyaca-v-excel/

    • excel:

      А вообще интересная задача. Вот как можно решить в вашем случае.

      =ЗНАЧЕН("01."&ТЕКСТ(A1;"ММ")&"."&ТЕКСТ(A1;"ГГГГ"))

      В А1 — дата конца месяца

    • excel:

      Можно протянуть начало месяца

      01.08.2016 01.09.2016 01.10.2016 01.11.2016 01.12.2016

      а конец месяц протянуть в другой строке как

      следующий месяц — 1

  • Захар:

    Здравствуйте. Нужен совет профессионалов. Имеется массив с 1000 числовых значений, необходимо разбить данные по диапазонам (от 0 до 5, от 5 до 10 и т. д.). Какую функцию для этого использовать?

  • Евгений:

    Добрый день! Помогите Получить правильную Формулу. Есть такая формула =ЕСЛИ(O7>12000;12000;ЕСЛИ(O7<8000;8000)) нужно добавить диапазон от 8000 до 12000, чтобы показывало сумму какая получится. Спасибо

    • excel:

      =ЕСЛИ(O7<8000;8000;ЕСЛИ(И(O7>=8000;O7<12000);O7;12000))

  • Алексей:

    вложение Безымянный

    Здравствуйте! Помогите пожалуйста решить такую задачку. Нужно сформировать отчёт по месяцам. Т.е. если выбирается месяц «ЯНВАРЬ», то в следующих ячейках должны появиться значения из других таблиц этой книги. Если выбираем «ФЕВРАЛЬ», то соответственно другие значения. Пробую сделать это через функцию «ЕСЛИ». но дело в том что эта функция позволяет создать формулу только с 7 степенями сложности, т. е. только на семь месяцев, а очень бы хотелось на все 12.

  • Татьяна:

    Работаю над таймингом проекта, поэтому нужно и таблицу составить, а потом диаграмму нарисовать. Я правильно поняла, что прочерк обозначает свободные данные? Как же тогда длительность рассчитать с этим прочерком?(((((((

    • excel:

      Я правильно поняла, что прочерк обозначает…

      Думаю это я должен спрашивать у вас. К тому же у вас в примере нет прочерков.

      Возможно если у вас в окончании указан прочерк, это означает что задача еще открыта. Тогда видимо нужно ставить текущую дату. Можно поставить функцию =СЕГОДНЯ() — это текущий день

  • Татьяна:

    Благодарю за оперативность, прошу прощения за повтор, не видела ответа, и своего комментария тоже не видела в числе добавленных. Если человек проходит проверку службы безопасности, ему предоставляют обучающие материалы. Если не проходит-соответственно, ничего не получает, ищем следующего.

    • excel:

      Как из вашего файла понять прошел сотрудник проверку или нет? Если в длительности больше 0, тогда например так

      =ЕСЛИ(И(G8="Проверка сотрудника службой безопасности банка";H8>0);"Предоставить материалы";"")

  • Татьяна:

    вложение  _проект-1.xlsx

    Здравствуйте! Помогите, пожалуйста: если в длительности работ заданы сроки цифрами, а в некоторых ячейках вместо цифр стоят прочерки, как сделать так, чтобы зависимости данных сохранились? Какую функцию лучше использовать, чтобы при выполнении одного условия перемещались в след.этап, при невыполнении, соответственно, отказ в след.этапе?

  • Татьяна:

    вложение  _проект.xlsx

    Здравствуйте! Помогите, пожалуйста, разобраться: если в длительности проекта основные этапы обозначены цифрами, но есть ячейки, содержащие прочерк, как их увязать со следующими ячейками, если каждая следующая дата должна «вытекать» из предыдущей? И еще один вопрос. Если выполняется одно условие, происходит переход на второй этап. Если не выполняется, то ничего не происходит. Какая формула здесь подойдет? Буду признательна за ответ.

    • excel:

      если в длительности проекта основные этапы обозначены цифрами, но есть ячейки, содержащие прочерк, как их увязать со следующими ячейками, если каждая следующая дата должна «вытекать» из предыдущей?

      С помощью функции если. Если в ячейке X прочерк, то брать дату выше, иначе — берем текущую дату в X.

      Если выполняется одно условие, происходит переход на второй этап. Если не выполняется, то ничего не происходит.

      Из описания не понятно. Какое условие должно выполняться, что значит переход на второй этап? А главное что вы хотите заполнить, проверяя указанное?

  • дарья:

    вложение Screenshot_27

    Сформулировать нужно формулу для ячейки «Даты отгула». Формула должна работать так: =если(в ячейке число больше нуля; то выводить слово "Переработка "и «дату вверху, где месяц»; иначе выводить слово «Отгул» и «дату вверху, где месяц»

    До этого в этот столбик писали все вручную, теперь охота чтоб автоматически

    • excel:

      каждую ячейку проверять через если не вариант. Я бы сделал где-то сбоку два дубля всего месяца. в одном дубле сделал бы проверку на больше 0 и отобразил вместо часов дни переработки.

      Во втором дубле то же самое, но все числа меньше ноля — так же вместо часов нужно отобразить дату переработки.

      Если пусто, то ноль или тоже пусто.

      После этого сцепляете все ячейки, сначала отгул, потом переработки

  • Антон:

    вложение  -2.xlsx

    Подскажите, как запрограммировать, чтобы итогом являлось определённое числовое значение, например число 25.

    При выполнении следующего условия:

    — в заданном интервале, например таком как А1:D1, появляются разные числовые значения, например от 1 до бесконечности, итогом действия с появлением числовых значений, больше нуля, всегда должно быть 25.

    Не появление в заданном интервале числовых значений больше нуля влечет итог равный нулю.

    • excel:

      Вы как раз в статье про ЕСЛИ.

      Вам нужно прописать условие. Если сумма A1:D1 > 0, то 25, иначе 0

  • GoogleEarth:

    Поэтому у функции ЕСЛИ возможны два результата. Первый результат возвращается в случае, если сравнение истинно, второй — если сравнение ложно.

  • Марат:

    Привет. Помогите пожалуйста. Есть столбец, в котором только значения 0,1,2,3,4 У меня это — 0 = используется, 1 = в наличии, 2 = брак, 3 = демонтаж. Столбец L. Как сделать так, чтобы где то внизу была таблица: Используется: Х штук. В наличии: Х штук. И т.д. Чтобы посчитать.

  • Андрей:

    Есть строка с датами вида 11.апр, 13.апр, 17.май, 02.июн, 07.июн, 01.авг, 17.сен, 19.сен, и т.д.

    Необходимо подсчитать сколько было упоминаний июня, сколько августа и т.д. 

    Спасибо.

    • excel:

      Если даты в формате дат, а не текста, то в следующей строке напишите

      =ТЕКСТ(A1;"ММММ")

      где 1 — это ваша строка с датами

      Протяните формулу на всю длину.

      Это формула во второй строке отобразит только название месяца по дате.

      Далее используйте СЧЁТЕСЛИ. Вот тут показано как пользоваться sirexcel.ru/priemi-excel/...achenij-v-excel/

  • Лиза:

    Скидка на оплату за секцию по следующему правилу: Для всех боксеров из Казахстана, а также на всех спортсменов, не достигших 15 лет, скидка на стоимость 5%

    Какую формулу необходимо применить, подскажите пожалуйста

    • excel:

      Функция ЕСЛИ, условия нужно прописать через функции «И».

  • ValenVik:

    Добрый день. Подскажите, пожалуйста, с помощью какой формулы можно занести в Excel следущий алгоритм:

    Если ячейка А1>=0,000001, то проставляется значение «0»

    Если ячейка А1=0, то анализируется ячейка А2

    Если ячейка А2>=0,000001, то проставляется значение «0»

    Если ячейка А2=0, то анализируется ячейка А3

    Если ячейка А3>=0,000001, то проставляется значение «1»

    Если ячейка А3=0, то проставляется значение «0»

    Спасибо

  • Анастасия:

    Здравствуйте! Подскажите как составить формулу: если А1>=1000, то делим на 4, а если А1>=999, то делим на 5.

    • excel:

      Точно правильно написали?

      делим на пять если А1 больше ли равно 999 но меньше 1000?

  • Pilar:

    дОБРЫЙ ДЕНЬ!

    помогите, пожалуйста, найти ошибку в формуле:

    =СЧЁТЕСЛИМН('[Отгрузки.xlsx]MAIN LIST'!$T:$T, «09.05.2016:13.05.2016»,'[Отгрузки.xlsx]MAIN LIST'!$R:$R, «ФАМИЛИЯ1, ФАМИЛИЯ2»)

    выдаёт нулевой результата, хотя значение должно быть большим.

    спасибо.

    • excel:

      посмотрите урок на эту тему: sirexcel.ru/priemi-excel/...achenij-v-excel/

    • excel:

      А зачем вы даты и фамилии указываете в формуле. Почему не делаете просто ссылку на ячейки. Думаю ошибка в этом. Числа (даты) как минимум у вас как текст указаны

  • Simonov Vladimir:

    Помогите пожалуйста найти ошибку в формуле. Пытаюсь рассчитать методику расчета сброса загрязняющих веществ в водный объект (привязка к дате) Сама формула К(вг)=ЕСЛИ(B5=B21 или B22 или B29 или B30 или B31 или B32; «1,15»;ЕСЛИ(И(B5=B24 или B25 или B23); «1,25»;ЕСЛИ(И(B5=B26 или B27 или B28); «1,1»; «Ошибка»)))

    • excel:

      ИЛИ записывается по-другому. Если вы сравниваете B5 то нужно записывать вот так

      =ЕСЛИ(ИЛИ(B5=B21; B5=B22; B5=B29; B5=B30... и т.д. 

  • Андрей:

    вложение  Strategy1.xlsx

    Здравствуйте, помогите написать формулу пожалуйста. Мне необходимо расчитать математическое значение при котором обязательным условием будет то, что из 3 х вариантов, 1-н вариант сработает . То есть ИЛИ D5*E5; ИЛИ D5*F5 ; ИЛИ E5*F5 как вбить это в в условие ЕСЛИ?! Если какое то из эти утверждений верно, чтоб получить математический расчет... Спасибо...жду от вас помощи, уже 3 ий день не могу найти правильную формулу(((

    • excel:

      Что значит сработает?

      «Если какое то из эти утверждений верно» какое утверждение? у вас просто перемножения D5*E5 и т.д. тут нет утверждения

  • Алесенька:

    Добрый день! Подскажите, пожалуйста, где ошибка в этой формуле, пишет "когда первый символ — знак равенства (=)...... "

    =ЕСЛИ(G1 «12»;C13*80\100*12+C13*(G1-12); ""))

    • excel:

      Попробуйте вот так:

      =Если(G1="12";C13*80\100*12+C13*(G1-12); ""))

      • Павел:

        Добрый день.

        Подскажите как построить формулу «Если»

        Мне нужно чтобы показатель в ячейке при

        (90%-94,99%) — был 500

        (95%-98,99%) — был 1000

        (99%-100,99%) был 2000

        (101%-120%) при каждом проценте повышения от 101% до 102% к последнему значению 2000, добавлялось 100 едениц.

      • Алесенька:

        Так тоже не получилось. Пишет тоже самое.

        • Алесенька:

          Может Вы мне поможете написать формулу. Нужно рассчитать больничные. Если человек болел меньше 12 дней, то считается 80% от з/п, если болел больше 12, то считается за 12 дней- 80%, а за остальные дни больничного 100%

          Буду очень Вам благодарна, если поможете!

          • Алесенька:

            Ой, спасибо большое!!!!!!! Это я что-то намудрила с формулой.

          • excel:

            =Если(G1<=12;C13*G1*80/100;12*C13*80/100+(G1-12)*C13)

            С13 — оплата за день

            G1 — кол-во больничных дней

            Рассчитываем оплату только за больничные дни (которая без условий равна G1*C13)

  • Евгений:

    Здравствуйте! Интересует как подсчитать кол-во строк в которых встречаются значения в двух ячейках, но, чтоб если только в одной или ни в одной то она не учитывалась. Например есть 4 столбца A,B,C,D в столбце А географическое положение, в столбце B пренадлежность (человек, животное, насекомое...) В столбце C — класс (хладнокровное, теплокровное, хищное, травоядное ...). Так же в таблице существует допустим заполнена ячейка животное но не заполнена ячейка класса. Например я хочу посмотреть сколько животных хищников есть Сибири, но, чтоб туда не попали те, у которых не заполнена одна из ячеек. Спасибо.

  • Александр:

    вложение  -1.xlsx

    Добрый день! помогите пожалуйста решить проблему со списками (есть 2 столбца в одном наименование во втором цена) необходимо сделать выпадающий список и при выборе наименования автоматически подставлялась цена в соседнюю ячейку.

    Пример во вложении, список выпадающий сделал, как быть дальше не знаю, помогите.

  • Стас:

    Добрый день ! Помогите. Имеется список с фамилиями и оценками, как сделать чтобы фамилия имеющая оценку 2 отобразилась на листе двоечники, то есть на другом листе, автоматом, получится должен список двоечников.

  • Татьяна:

    вложение  .xlsx

    Нужна помощь.

    Нужно рассчитать реальный план потребности по месяцам, если в утвержденном плане 6 штук в июле, а использовано по факту 8 в январе, значит в июле должен быть 0. как рассчитать если перерасход, чтоб отнимало в следующих месяцах, а если не использовано, то оставляло план по месяцам??? столбец Е-Р это утвержденный план; R-AC факт использования

  • Alex:

    Добрый вечер.

    Возможно ли сделать так, что бы по типу этой формулы

    =ЕСЛИ(C5=2;Price!D24; «-»)

    При изминение значения ячейки С5, формула выводила на цену, привязанную к значению.

    • excel:

      Что значит привязанную к значению? Без подробностей не понятно, что вам требуется. Формула будет работать и все время будет возвращаться Price!D24

  • Михаил:

    Здравствуйте, подскажите, пожалуйста, как сделать в эксель:

    если в ячейке «например А1» число >10, то в ячейке «например А2» выводится число 1000, если в той же А1 >20, то выводится число 2000, если 30, то 3000 и так далее.

  • Юрий:

    Добрый день. Возникла такая проблема, есть таблица в 1 столбце указаны дата и время, нужно убрать время больше 12 часов. пример ячейки 18.09.2015 12:00:00

  • Артем:

    вложение  123.xlsx

    Добрый день! Помогите решить задачу! В задании необходимо написать формулы для каждого фрейма, чтобы очки считались автоматически при любых возможных подставленных значениях.

    • excel:

      Задача вполне решаема. Для упрощения сделайте доп. ячейки (промежуточные результаты). Чтобы баллы подсчитывались после каждого страйка и spare. Тогда не придется проверять ячейки на несколько страйков вперед. Самостоятельно нет времени делать. Пробуйте сами, что не получится спрашивайте

  • GVF:

    "" отражается на графике как 0. Подскажите, пожалуйста, можно ли сделать, чтобы "" отражалось как пустая ячейка?

    • excel:

      увы, такого способа не знаю. Можно удалить именно этот ноль на самом графике вручную. Правда, конечно, это не универсальное средство.

  • Татьяна:

    вложение  .xlsx

    Доброе время суток. Могли бы Вы мне помочь??? Как можно сделать, чтоб при выборе продукта из прайса на следующей странице автоматически выходила ценна. Заранее Благодарю

  • Роман:

    Добрый день! Подскажите как сделать что бы в функции при определенных показателях выскакивало нужное слово. Например если меньше 100 то -ПРОБЛЕМА, если больше 100 то-НОРМА

    • excel:

      В статье как раз рассматривается подобный вариант. Например так

      =ЕСЛИ(A1<100; «Проблема»; «Норма»)

      Если меньше 100 то будет проблема, если нет (то есть больше или равно 100), то будет «Норма»

  • Екатерина:

    Добрый день Очень нужна помощь. Как только уже не пыталась, не получается.

    Есть ячейка в которой считается % выполнения допустим J3 и есть ячейка в которой исходя из % выполнения (J3) должен уставиться показатель (пусть она будет К3). Либо 0%, либо 150% либо то что действительно стоит в ячейке J3. Суть такова если % Выполнения (J3) менее 50% то 0, если % выполнения (J3) от 50% до 150% то что просчиталось в J3, если %Выполнения больше 150% то 150%.

    Например:

    если J3=160% то значение в К3 должно быть 150%

    если J3=49% то значение в К3 должно быть 0%

    если J3= (от 50% до 150%) например 65% то в К3 должно стоять 63%

    Как прописать правильно?

  • LEO:

    Помогите пожалуйста, что в этой формуле неправильно E7=C7*(1-((D7>14)*15%+(D7>29)*40%+1%*МАКС(0:D7-30)))

  • артем:

    Здравствуйте, упадаю на Ваш богатый! Не удается задать следующее условие =ЕСЛИ(M7=5;8500);ЕСЛИ(И(10>=M7;M7>5);F69);ЕСЛИ(И(20>=M7;M7>10);F70);ЕСЛИ(И(30>=M7;M7>20);F71);ЕСЛИ(И(40>=M7;M7>30);F72);ЕСЛИ(И(50>=M7;M7>40);F73);ЕСЛИ(И(60>=M7;M7>50);F74). Результат #знач...

  • Марина:

    Добрый вечер!

    Скажите пожалуйста, как вбить формулу:

    — есть несколько таблиц (на одном листе), в графе «Исполнитель» указаны сотрудники, рядом графа с суммой. Можно ли задать формулу отдельно (в Основной таблице) по каждому сотруднику, что если Фамилия-Иванов стоит в графе «Исполнитель» то сумма рядом в его строке, плюсуется этому сотруднику в Основную таблицу. Если фамилия Петров — то сумма плюсуется Петрову в Основную таблицу.

    • excel:

      Здравствуйте! можно добавить в основной таблице еще один дополнительный столбец и с помощью ВПР: sirexcel.ru/priemi-excel/...xcel_s_primerom/

      Подтянуть данные по каждому сотруднику и потом просуммировать.

      Если сотрудника нет, то ВПР выдаст ошибку, тогда равно текущей сумме, если ВПР не ошибка, то применяем снова ВПР, возвращаем сумму из таблице и суммируем с текущей

  • Кирилл:

    вложение  2.xlsx

    Здравствуйте. Помогите, пожалуйста.

    У меня есть основной массив данных. Например, список участников соревнований. Строка для каждого участника выглядит примерно так: Аn — ФИО, Bn:Un — Разделение по дням соревнований (первый день, второй и т.д. ) Vn — итог.

    На каждый день соревнования заводится новый лист, где участники набирают определенное количество очков. Участники на каждый день разбиваются по разным группам, следовательно на листе 1 Вася будет в ячейке А1, во второй день он может быть в ячейке F1 и т.д. Все имена уникальны. Листы по дням содержат информацию о дне соревнования. Там есть графы, куда вписываются очки за определенные действия, графа с коэффициентом и итог за день.

    Вернемся к первому листу с общим массивом. В столбец каждого дня заносятся очки из результатов соответствующего по принципу: «Всего» деленное на «коэффициент».

    Необходимо, что бы в ячейки результатов в списке участников вносились данные по дням автоматически. Если Вася соответствует Васе, то «Всего» разделить на «коэф» и вписать результат. Возможно ли так сделать? Пример прикрепил

    • excel:

      Если просто, то я бы для первого дня написал бы формулу с помощью функции ИНДЕКС и ПОИСКПОЗ: sirexcel.ru/priemi-excel/...cel-s-primerami/

      Далее эту формулу скопировал бы на другие дни, поменяв только название листов.

      То есть подготовить файл сразу на все дни. Используя вышеуказанные функции вы не будете зависеть от расположение фамилии по строкам.

      Можно и по-другому, использовать сложную формулу, скорее всего с помощью формулы ДВССЫЛ и выше указанных, но сразу решение в голову не приходит. Дело не 5-ти минутное.

      • Олег:

        Добрый день подскажите пож-ста где ошибка в формуле

        =ЕСЛИ(E12={1000;2000};E12*E12+(E12*0,35));ЕСЛИ(e12>2000;e12+(e12*0,25)))

        смысл формулы пытался задать такой

        если меньше 1000 то прибавляем 50%

        если от 1000 до 2000 то прибавляем 35%

        если выше 2000 то прибавляем 25%

        • excel:

          Можно вот так — используйте оператор И

          =ЕСЛИ(E12<1000;E12+E12*0,5;ЕСЛИ(И(E12>=1000;E12< =2000);E12+E12*0,35;E12+E12*0,25))

          либо с помощью впр: sirexcel.ru/priemi-excel/...xcel-s-primerom/

          • Олег:

            спасибо, все заработало!

  • Алексей:

    Подскажите пожалуйста как прописать формулу проверяющую следующее : соответствует ли А1 В1, если да то «хорошо» если нет то (содержит ли В1 что нибудь из А1, если да то «нет отчества» если нет то «несоответствие»)

    немогу сообразить никак ((

    А В

    1 Иванов Иван Иванов Иван Иванович

    2 Петров Андрей Петров Андрей Сидорович

    3 Шемякин Алексей Шемякин Алексей

    4 Свиридов Иван Пронин Андрей Витальевич

    • excel:

      Проверить есть Имя и Фамилия в ФИО можно с помощью функции НАЙТИ

  • Алексей:

    День добрый ! Помогите пожалуйста прописать формулу — сравнение значений ячеек в двух столбцах А и В, если значение в ячейке столбца В меньше либо равно значению в столбце А, то значение в столбце В нужно увеличить на 1.

  • Александр:

    Здравствуйте!

    Значение ячейки «C» является результатом вычитания ячейки «B» из ячейки «A». Результатом может быть минусовое число (5-10= «-5»).

    Как проверить вначале, чтоб ячейка была больше нуля и если меньше, то присвоить ячейке «С» просто ноль, если больше — то приплюсовать ей ечейку «D»?

    Спасибо заранее за помощь.

    • excel:

      =ЕСЛИ((B1-A1)<0;0;(B1-A1)+D1)

  • Максим:

    Здравствуйте. Подскажите вот такая задача: Есть лист 1 в котором в вписываем А3-99 порядковые № от 1 до 97, столбец В3-99 наименование, С3-99:Е3-99 по 3 характеристики на каждое именование, во втором листе есть паспорт ячейка В1 № паспорта и 3 ячейки в которые должны автоматически из первой таблицы переноситься данные. Хочется чтобы написав № в ячейку паспорта 3 других значения переносились автоматически. Пример:

    лист1.

    А В С D Е

    1. 1 — Суглинок — 2.2 кг/см3 — 15,12% — 1,56 кг/см3

    лист 2.

    А

    1. № паспорта (вводим вручную),

    2. Плотность увлажненного грунта — (пишется автоматом в зависимости от № п.п.)

    3. Влажность — (пишется автоматом в зависимости от № п.п.)

    4. Плотность скелета грунта — (пишется автоматом в зависимости от № п.п.)

    Заранее благодарен.

  • Алексей:

    Что делать если при вводе формулы с использованием «ЕСЛИ» число уровней вложенности превышает 64?!

  • Оксана:

    Помогите пожалуйста с формулой, третий день бьюсь, все никак.

    Лист1-таблица в которой необходимо чтобы автоматически вносились данные о сотрудниках(их всего 103 чел., но в таблице будет только 5 чел.)

    Хотелось бы, чтобы при ручном вводе только таб.№(А) — ФИО(D) и №страховки(E)автоматически подтягивались из Листа 2.

    Лист2-Список таб.№ (С3:С105), ФИО сотрудников(Д3:Д105), №страховки (Е3:Е105).

  • Алёна:

    Подскажите пожалуйста как найти надбавку за стаж- Если стаж работы не превышает 5 лет, то надбавка за стаж равна (10+n)% от оклада, от 5 до 10 лет (15+n)% от оклада и свыше 10 лет – (20+n)% от оклада. При вычислениях используется функция ЕСЛИ()

    • excel:

      =ЕСЛИ(A1<5;(10+n)%;ЕСЛИ(A1>5;(20+n)%;(15+n)%))

      Как-то так, вместо (10+n)% — указать расчет оклада, A1 — это стаж

  • юлия:

    Здравствуйте, такая задача, есть формула ЕСЛИ(СУММ(А1:А2)=0; «ИДИТЕ»; А1/А2) при значении А2=0, выдается ошибка «Деление на ноль». Как переписать эту формулу, чтобы избежать ошибки.

    • excel:

      Добрый день! Ошибка никуда не пропадет, ее можно только скрыть.

      =ЕСЛИОШИБКА(ЕСЛИ(СУММ(A1:A2)=0; «ИДИТЕ»; А1/А2); "")

      если будет ошибка, то будет пусто

  • Ольга:

    Да конечно скачала.Но у меня не получается. Нажимаю «вставить функцию ЕСЛИ». Выходит табличка, где нужно расписаться лог. Выражение, истину и ложь. Спасибо за помощь-не буду Вас больше беспокоить

    • excel:

      Вот решение. Отличие только в том, что в первом случае «вид занятий» и ставка вынесены для удобства в отдельную табличку, а тут все в формуле написал. Насколько я понял, что вам именно так надо без лишних табличек

      yadi.sk/i/tm0JJ8DZexPtq

    • excel:

      Если не разберетесь, то пришлите сам файл на [email protected]

      Если там нужно только формулу прописать, я вам сделаю

      • Александр:

        Александр. Добрый день.

        Не могу прописать формулу помогите.

        Смысл такой. нужно что бы рядом с всплывающим окном показывало число то которое стоит напротив этой записи.

        • excel:

          Вопрос не понятен. Что за всплывающее окно?

    • excel:

      В вашем случае, проверка будет на то, что в ячейке «Вид занятий» равно «Индивидуальные занятия», если равно, то это истина и будет перемножение коэ-та, если не равно, то снова проверка на если, проверяется если ячейка в «Вид занятий» равно «Групповые занятия», если равно, то идет перемножение кол-ва часов на соответствующий коэ-т, если нет, то снова проверка.

  • Ольга:

    Файл с заготовкой

  • Ольга:

    Доброе утро! Вот заготовка к и условия задачи. Никак не пойму в данной задаче что является истиной, что ложью. Подскажите пожалуйста.Задача: Поле "Оплата инструктору " вычислить по формуле (используйте функцию ЕСЛИ) исходя из тарифа- дежурство в зале-120 руб. за час, инд. занятия- 200 руб. за час, гр. занятия- 180 руб. за час.

    Дата Инструктор Вид занятия Название тренировки Длительность тренировки Оплата инструктору

    01.02.2015 Иванов. А.А. Индивидуальные занятия Йога 2

    02.02.2015 Петров С.С. Групповые занятия Аэробика 1,5

    03.02.2015 Сидоров М.М. Групповые занятия Фитнес 1,5

    04.02.2015 Семенов П.П. Дежурство в зале Плавание 1

    05.02.2015 Котов К.К. Индивидуальные занятия Аквааэробика 1

    06.02.2015 Иванов. А.А. Индивидуальные занятия Йога 2

    07.02.2015 Петров С.С. Дежурство в зале Аэробика 1,5

    08.02.2015 Сидоров М.М. Групповые занятия Фитнес 1,5

    09.02.2015 Семенов П.П. Групповые занятия Плавание 1

    10.02.2015 Котов К.К. Индивидуальные занятия Аквааэробика 1

    11.02.2015 Иванов. А.А. Индивидуальные занятия Йога 2

    12.02.2015 Петров С.С. Групповые занятия Аэробика 1,5

    13.02.2015 Сидоров М.М. Дежурство в зале Фитнес 1,5

    14.02.2015 Семенов П.П. Групповые занятия Плавание 1

    15.02.2015 Котов К.К. Индивидуальные занятия Аквааэробика 1

    16.02.2015 Иванов. А.А. Индивидуальные занятия Йога 2

    17.02.2015 Петров С.С. Групповые занятия Аэробика 1,5

    18.02.2015 Сидоров М.М. Групповые занятия Фитнес 1,5

    19.02.2015 Семенов П.П. Групповые занятия Плавание 1

    20.02.2015 Котов К.К. Индивидуальные занятия Аквааэробика 1

    21.02.2015 Иванов. А.А. Дежурство в зале Йога 2

    22.02.2015 Петров С.С. Групповые занятия Аэробика 1,5

    23.02.2015 Сидоров М.М. Групповые занятия Фитнес 1,5

    24.02.2015 Семенов П.П. Групповые занятия Плавание 1

    25.02.2015 Котов К.К. Индивидуальные занятия Аквааэробика 1

    26.02.2015 Сидоров М.М. Групповые занятия Фитнес 1,5

    27.02.2015 Семенов П.П. Групповые занятия Плавание 1

    28.02.2015 Котов К.К. Дежурство в зале Аквааэробика 1

  • Ольга:

    Добрый день! Помогите пожалуйста решить задачу: рассчитать оплату инструктора по фитнесу используя функцию ЕСЛИ, если известны тарифы оплаты за 1 час: дежурство-120 руб, групповые занятия-180 руб, индивидуальные занятия-200 руб. Спасибо заранее

    • excel:

      Лучше использовать ВПР в данном случае

      yadi.sk/i/jFcg6BRHewhqo

      • Ольга:

        Напишите пожалуйста еще формулу с функцией ЕСЛИ

        • excel:

          Ольга, а я что написал? Если не то, что надо, тогда задавайте вопрос более полно, плюс приложите файл с заготовкой.

      • Ольга:

        Спасибо большое за вариант, но задача состоит именно в использовании функции ЕСЛИ

  • Станислав:

    Доброго времени суток!

    Помогите, пожалуйста, написать формулу, которая бы помогла выбрать минимальное значение из трёх при различных курсах и заполняемости таблицы.

    Имеется:

    D2 — Доллар

    E2 — Евро

    F2 — Фунт

    D6 =450

    E6 =350

    F6 =250

    Курсы (доллар, евро, фунт к рублю):

    L15 =60

    L16 =70

    L17 =90

    В ячейке G6 необходимо рассчитать МИНИМАЛЬНУЮ сумму в рублях (без использования доп. ячеек), при условии, что значение «0», либо пустая ячейка с ценой не будет приниматься во внимание (в противном случае минимальное значение будет «0»).

    Формула ниже работает, но если значениях всех ячеек указаны и больше «0»:

    МИН(ЕСЛИ(D6=0;МИН(E6*L16;F6*L17);МИН(D6*L15;E6*L16;F6*L17));ЕСЛИ(E6=0;МИН(D6*L15;F6*L17);МИН(D6*L15;E6*L16;F6*L17));ЕСЛИ(F6=0;МИН(D6*L15;E6*L16);МИН(D6*L15;E6*L16;F6*L17)))

    ЛИБО:

    =ЕСЛИ(ИЛИ(D6=0;E6=0;F6=0); «ПРОБЛЕМА»;МИН(D6*L15;E6*L16;F6*L17))

    Стоит указать в одной из ячеек значение «0» или вовсе ничего не указывать, то выражение обнуляется.

    • excel:

      Как вариант так

      =МИН(ЕСЛИ(D6=0;100000;D6)*L15;ЕСЛИ(E6=0;100000;E6)*L16;ЕСЛИ(F6=0;100000;F6)*L17)

      где 100000 это максимальное число, которое не может быть ценой в реальном примере

      • Станислав:

        Спасибо!!! На это фантазии не хватило)))

  • Дима:

    Помогите сделать в Excal

    • excel:

      Добрый день! Такие задачи я не решаю, хоть она и простенькая. Подготовьте полностью таблицу, внесите данные, и если потребуется составить формулу, я помогу. А так у меня времени нет это делать за вас)

  • Дима:

    Автогонщик участвовал в пяти этапах соревнований. Известны средняя скорость движения автомобиля на каждом из этапов (в км/час) и время, затраченное на прохождение дистанции этапа (в час). Подготовить лист для определения общей длины тех этапов, на которых средняя скорость движения автомобиля была больше 200 км/час.

  • VICK:

    Здравствуйте, помогите, пожалуйста. Я не большой специалист в использовании формул, но вот методом тыка дошла до следующей формулы, дающей мне желаемый результат: =IF (F4=Lists!B3;Expenses!E4;0)+IF (Expenses!F5=Lists!B3;Expenses!E5;0)+ и т.д.

    Смысл в том, что значение столбца F всегда должно быть равно значению ячейки B3 вкладки Lists. Если условие выполняется, следует выбирать значение столбца E, того же ряда. Все выбранные значения затем суммируются. Формула в таком виде работает, но забивать вручную все ячейки столбца F для сравнения просто не реально!

    Модет есть какой-то другой способ?

    • excel:

      Без файла не очень понятно, но как я понял, вы можете сделать следующим способом

      =IF (F4=Lists!$B$3;Expenses!E4;0)

      закрепите B3 и тогда можно протянуть формулу на все строки, а потом все просуммировать.

      2-й способ, это просто в одной ячейке с помощью функции СУММЕСЛИ

  • Андрей:

    Здравствуйте всем. Очень ценная информация!!! А кто-нибудь занимался составлением графика учета рабочего времени с дневными и ночными сменами? Мне нужно сделать так, чтоб отдельно считались дневные и ночные часы. То есть, если в графике стоит 12, значит 12 считаются как дневные, а вот с ночными сложности...Человек заступает на смену в 20:00, и до 22:00 идут 2 часа дневных, и так же утром с 6:00 до 8:00 тоже 2 часа дневных... в графике ставят 4 и 8 часов в разные дни, но из них по 2 часа получаются дневные... вот как бы задать такое условие, чтобы дневные часы считались в одной ячейке, а ночные в другой... Заранее благодарен, если кто-нибудь поможет!!!

  • Алена:

    Спасибо все получилось, формула следующая =ИНДЕКС(Лист1!B:B;ПОИСКПОЗ(B8;Лист1!A:A;0);1)

    • excel:

      Ну я вам так и написал

      «Ой, сорри. Номер столбца нужно указать как 1, CTRL + SHIFT + ВВОД нажимать не надо

      =ИНДЕКС(Лист1!B:B;ПОИСКПОЗ(B8;Лист1!A:A;0);1)»

  • Алена:

    0 потому что точное сопоставление. написала 1 все равно пишет ссылка

  • Алена:

    я скопировала данные на новый лист, получилась такая формула =ИНДЕКС(Лист1!B:B;ПОИСКПОЗ(B8;Лист1!A:A;0);Лист1!B:B)

    но при нажатии кновки ввод или комбинации CTRL + SHIFT + ВВОД

    он мне пишет в ячейке «ссылка»

    Что не так сделала?

    • excel:

      И Алена, вы написали формулу с Лист1, Лист1 это лист с ссылками на другую книгу? и при этом вы находитесь и прописываете саму формулу на другом листе? так?

      • Алена:

        Нет,. на Лист1 располагаются данные без ссылок на другую книгу, формулу создаю на Лист2 в этой же книге

    • excel:

      Почему пишите 0? CTRL + SHIFT + ВВОД нажимать не надо

      =ИНДЕКС(Лист1!B:B;ПОИСКПОЗ(B8;Лист1!A:A;1);Лист1!B:B)

      • excel:

        Ой, сорри. Номер столбца нужно указать как 1, CTRL + SHIFT + ВВОД нажимать не надо

        =ИНДЕКС(Лист1!B:B;ПОИСКПОЗ(B8;Лист1!A:A;0);1)

  • Алена:

    У меня другой вопрос, можно ли эту функцию {=ИНДЕКС(K:K;ПОИСКПОЗ(B8;J:J;0);K:K)} переделать так чтобы диапозоны были из другой книги

    • excel:

      Чтобы не использовать CTRL + SHIFT + ВВОД, вместо K:K необходимо указать 1 — это номер столбца, он у вас один. Вот такую формулу и попробуйте на с другой книгой, я не помню будет она работать или нет.

      Если не будет, то делаете новый лист, там в ячейке A1 прописываете формулу Ваша_другая_книга_A1 и протягиваете вниз и влево, то есть делаете копию данных, простой ссылкой. При открытии данные будут обновляться, Индекс используете ссылкой на эту страницу. Потом можете скрыть этот лист, чтобы не мешал.

  • Алена:

    Добрый вечер. У меня формула есть: =ЕСЛИ(B8=[Книга3]Лист1!$A$1;[Книга3]Лист1!$B$1;0)

    Но у меня проблема заключается в следующем: вместо $A$1 и $B$1 мне нужно вставить диапозон. В итоге должно получиться следующее: лог_выражение после знака = должно выбирать из диапозона нужное значение, а ИСТИНА должна выбираться также из диапозона

    • excel:

      Добрый день! Нужно либо делать много вложенных ЕСЛИ, либо использовать обычную ПОИСКПОЗ — смысл в том, что используя ПОИСКПОЗ функция будет пытаться найти искомое значение B8 в столбце диапазона (который вместо $A$1), если найдет, то выдаст номер строки (порядковый номер строки в указанном диапазоне), если не найдет, то будет ОШИБКА Н/Д. Далее используете один раз функцию ЕСЛИ. Если ошибка, например, пусто, если не ошибка, то используете функцию ИНДЕКС — =ИНДЕКС(диапазон_тот_что_вместо_$B$1;номер_найденной_строки_в_виде_формулы; столбец_1)

      • Алена:

        Не получается. Формула получилась следующая: =ИНДЕКС(J:K;ПОИСКПОЗ(B8;J:J;0);K:K)

        В8 — артикул

        Диапозон J:J — артикулы

        Диапозон K:K — Цена

        После написания формулы должна выходить цена, поиск по артикулу

        • Алена:

          Спасибо, забыла нажать сочетание клавиш CTRL + SHIFT + ВВОД, а в итоге формула получилась следующая {=ИНДЕКС(K:K;ПОИСКПОЗ(B8;J:J;0);K:K)}

  • Евгения:

    Добрый день, помогите пожалуйста не могу разобраться.

    Мне нужно

    Базовая ставка- 15 000,00

    от 1 года до 2 лет — 10%-0,10

    от 2 лет до 3 лет — 20%-0,20

    от 3 до 4 лет — 30%-0,30

    от 4 до 5 лет — 40%-0,40

    свыше 5 лет — 50%-0,50

    Т.е. Если стаж от 1 до 2 лет, то базовая ставка умножить на коэффициент 0,1 и так все годы. Прописать формулой помогите пожалуйста.

    • excel:

      Добрый день! Совсем недавно, как раз, рассматривали интересное решение к данной задаче. Если не решили вопрос, то пишите — поможем

      vk.com/topic-57633334_30146627?post=89

  • ирина:

    ООО, получилось, спасибо еще раз!!!

  • ирина:

    так вы имели ввиду ЕСЛИ(I3<=2400000);18%*I3;ЕСЛИ(I3<=580000);432000+23%*(I3-2400000);ЕСЛИ(I3<=9300000);1214+28%*(I3-5800000);ЕСЛИ(I3<=13000000);2194000+34%*(I3-9300000);3452000+40%*(I3-13000000)))))

    • excel:

      А зачем вы добавили лишние скобки во многие выражения ЕСЛИ(I3< =2400000);18%*I3

      Пишите одно, потом исправляете.

      =ЕСЛИ(I3< =2400000;18%*I3;ЕСЛИ(I3<=58000;432000+23%*(I3-2400000);ЕСЛИ(I3<=9300000;1214+28%*(I3-5800000);ЕСЛИ(I3<=13000000;2194000+34%*(I3-9300000);3452000+40%*(I3-13000000)))))

  • ирина:

    Так тоже не получается, выдает что неправильно введен знак равенства и минус

    • excel:

      Пришлите итоговую формул (исправленную), которая не прнимается

  • ирина:

    Что не так в этой функции? мне выдает что неправильно введен знак равенства и минус, подскажите пожалуйста) ЕСЛИ(I3<=2400000;18%*I3;ЕСЛИ(I3<=580000;432000+23%*(I3-2400000);ЕСЛИ(I3<=9300000;1214+28%(I3-5800000);ЕСЛИ(I3<=13000000;2194000+34%(I3-9300000);3452000+40%(I3-13000000)))))

    • excel:

      Добрый день! Во второй части формулы, начиная с 28%(I3-5800000) и до конца, у вас не стоит знак умножить после процентов.

      • ирина:

        Большое спасибо!

  • Наталья:

    Я ошиблась

    Как составить формулу: Если сумма заказа превышает Nсуммы, то НДС 35%, а если сумма меньше или равно Nсуммы, то 40%

    • Юлия:

      у меня было похожее условие если план выполнен меньше чем на 10%, то премии нет, если выполнен больше чем 10% но менее 20%, то премия 5% и, т. д. я записала следующее

      в ячейке С сумма 100% бонуса, в ячейке F — просчитывался процент выполнения, в ячейке G я прописала формулу, отвечающую этим условиям, вот она =ЕСЛИ(И(F3F3;F3>=10);C3*0,05;ЕСЛИ(И(30>F3;F3>=20);C3*0,1;ЕСЛИ(И(40>F3;F3>=30);

      C3*0,15;ЕСЛИ(И(50>F3;F3>=40);C3*0,2;ЕСЛИ(И(60>F3;F3>=50);C3*0,25;

      ЕСЛИ(И(70>F3;F3>=60);C3*0,3;ЕСЛИ(И(80>F3;F3>=70);C3*0,35;ЕСЛИ(И(85>F3;F3>=80);

      C3*0,4;ЕСЛИ(И(90>F3;F3>=85);C3*0,5;ЕСЛИ(И(95>F3;F3>=90);C3*0,65;

      ЕСЛИ(И(100>F3;F3>=95);C3*0,75;ЕСЛИ(И(105>F3;F3>=100);C3*1;

      ЕСЛИ(И(110>F3;F3>=105);C3*1,03;ЕСЛИ(И(F3>=110);C3*1,07)))))))))))))))

  • Наталья:

    Как составить формулу: Если сумма заказа превышает Nсуммы, то НДС 35%, а если сумма меньше или равно Nсуммы, то 35%

  • Григорий:

    мне нужна помощь

  • OLEG:

    спасибо за дельные советы...

  • Oleg:

    а вот полный вариант раз так.

  • Oleg:

    ЧМ — Занимаемое командой место определяется по следующим критериям:

    – наибольшее количество очков;

    – лучшая разница забитых и пропущенных мячей;

    – наибольшее количество забитых мячей.

    ЧЕ — место в группе определяется по следующим критериям:

    – большее количество турнирных очков, полученных командами во встречах друг с другом;

    – лучшая разница забитых и пропущенных голов во встречах друг с другом;

    – большее количество голов, забитых в матчах друг с другом;

    т.е если на пример Бразилия и Мексика набрали одинаковое кол-во очков и у Бразилии разница мячей 5-3=2, а у Мексики — 3-3=0 и между собой сыграли Бразилия-Мексика 0-1, то в ЧМ выше будет Бразилия, а в ЧЕ — Мексика (личная встреча). ЧЕ — При равенстве очков у трёх команд вообще нужна таблица отдельно для них, а потом вернуться в основную (наверное коряво закрутил...). Не могу никак это всё оформить.

    • Oleg:

      столбцы забыл скрытые с формулами открыть...

  • Oleg:

    вот...

    • excel:

      Напишите, подробно в чем состоит задача.

  • Oleg:

    есть электронная таблица ЧМ по футболу, нужна помощь для составления таблицы ЧЕ (другой регламент распределения мест в группе при равенстве очков у двух и более команд). ????

    • excel:

      Без примера ничего не понятно

      • Oleg:

        у меня файл 716КБ

        • excel:

          Поменял настройки на 2мб

          • Oleg:

            у меня был файл xls. и вставки изображения, всё исправил...

      • Oleg:

        а куда пример вставить ???

  • Oleg:

    вот пример:

    =ЕСЛИ(ИЛИ(A2="!!! «;В2=»!!!;С2="!!! «;D2=»!!! ";и т. д.); "!!! "; "") т.е. проверяю столбец на наличие хотя бы одного "!!! "

    это перечисление набираю вручную, а можно ли как то быстрее ??? или другим способом ???

    • excel:

      Олег, на первый взгляд только так, но все зависит от конкретной задачи.

      Свободны ли данные под A2, B2 и т.д. ? важно ли для вас знать в каком столбце будет находится значение !!! или просто нужно знать есть в каком либо столбце или нет

      • Oleg:

        я немного ошибся...

        вот как

        =ЕСЛИ(ИЛИ(A2="!!! «;А3=»!!! «;А4=»!!! «;А5=»!!! ";и т. д.); "!!! "; "") т.е. проверяю столбец на наличие хотя бы одного "!!! "

        в ячейке А1 должно быть "!!! " если хотя бы в одной из ячеек столбца после А2 есть "!!! ". в какой строке не важно.

        Спасибо...

        • excel:

          Так, нет. Эта функция не будет работать. Используйте просто ВПР

          =ВПР("!!! ";$A$2:$A$12;1;0)

          Если есть, то вернется это значение, если нету такой ячейки, то будет ошибка

        • excel:

          Тогда можете воспользоваться функцией ПРОСМОТР

          =ПРОСМОТР("!!! ";A2:A12)

          Если в массиве A2:А12 будет ячейка с !!!, то вернется !!!, если нет, то будет ошибка. Вот от этого и отталкивайтесь

          • Oleg:

            работает как я хотел, здорово...

          • excel:

            Тогда так: =ЕСЛИОШИБКА(ВПР("!!! ";$A$2:$A$12;1;0); "")

          • excel:

          • Oleg:

            только хотелось бы при отсутствии !!! не ошибку, а пустую ячейку.

          • Oleg:

            понял, спасибо...

Добавить комментарий

Ваш e-mail не будет опубликован. Все поля обязательны для заполнения.